All Collections
Cinema 4D
Poliigon Plugin for Cinema 4D (Beta)
Poliigon Plugin for Cinema 4D (Beta)

How to install and use the alpha Poliigon plugin for Cinema 4D

Updated over a week ago

v0.7.1 released March 21st, 2024
Works in Cinema 4D 2023 and 2024
Currently supports: Redshift, Octane, Corona, V-Ray, Arnold

This product entered Open Beta in March 2024. Please share your feedback:

How to Install and Use the Plugin

  1. Download the plugin (link above) file and extract it into a folder on your computer.

  2. Locate and open Cinema 4D’s plugin folder. To find this:

    1. Start Cinema4D

    2. Open preferences (Menu Edit → Preferences…)

    3. Click on the “Preferences Folder…” button at the bottom left (highlighted in green via screenshot below)

    4. Explorer/Finder will open with a Maxon folder selected (e.g. Maxon Cinema 4D 2023.2_…).

  3. Navigate the "plugins" sub-folder

  4. Unzip the plugin into the just-opened plugins folder. Unpacked it should be a sub-folder poliigon-plugin-cinema4d (see screenshot below)

  5. (Re-)start Cinema 4D

  6. The extension is now available from the topbar: Extensions > Poliigon menu item

Opening the preferences folder

Location once installed

Indepth How-To:

Background

This plugin allows you to browse, purchase, download, and import Poliigon assets all without ever leaving Cinema 4D. It supports loading textures, models, and HDRIs.

It supports Cinema 4D 2023+.

User Account Setup

  1. Go to Extensions > Poliigon

  2. In the dialogue that opens, go ahead and login either via Browser or email

    1. Clicking on Log In via Browser will open a webbrowser. If you are already logged into Poliigon on this browser, you will be auto-logged in.

    2. Clicking on "Switch to Login via Email" will let you instead directly enter your password and email. Neither will be stored locally.

  3. Next, you will be prompted to select where you want to download and import Poliigon assets from.

    1. You can select a pre-existing folder, and Poliigon assets will be recognized. Be aware though: This plugin and render setups require the Metalness workflow (unlike the legacy Material Converter for C4D), and therefore may still prompt you to re-download assets that are local in the Specular format.

  4. You will see a screen clarifying how to use this plugin

  5. Finally, you can start purchasing, downloading, and importing assets

Consider Docking

You can dock the plugin window like any other window in Cinema 4D, by dragging the top-left window menu into another spot in the main window interface. You can save this layout for the next time you open C4D by going to: Window > Customization > Save Layout As or Save as Startup Layout.

Navigating the plugin

The plugin is broken into several top-level views:

Tabs

  • Online Assets: This is the equivalent view as navigating on the website. Newest published assets will appear first.

  • My Assets: This shows only assets you have already purchased.

  • Account: This shows your current account and plan information. You can click here to check your Asset Balance or open the website to change your plan.

  • Help: Quickly opens this page as well as the survey feedback. In the future, we will have more in-app help and tips

Top-right header buttons

  • Refresh: In case you are having any trouble, or need to reload the page after making a purchase separately on the website, use this circular-arrow button.

  • Preferences: Using this cog icon, you can quickly open the C4D plugin preferences window.

Searching and categories

Click on categories in the sidebar in addition to searching for keywords in the search field at the top. These interactions function equivalently to searching on the Poliigon website.

Asset Grid

Hover over an asset grid item to preview, purchase, download, and import. Using the dropdown menu also lets you open the asset on the website as well as open the local file. More features coming soon.

Preview asset

Not sure which asset to purchase for your scene? Try before you buy! With any mesh(es) selected, press the eyeball icon on a Material you haven't purchased yet. This will download and import a low-resolution, watermarked PBR material for you to visualize.

Try previewing a few materials before picking one to purchase! Available for textures only.

Purchase

You can purchase an asset inside the plugin using your Asset Balance. Free assets will be marked as Free and will not use up your balance.

Download Asset

Assets will automatically download after purchasing. Assets you have previously purchased will also appear as ready for download, if not already detected locally.

You can turn off auto-download in user preferences (cog icon top-right). There, you can also choose the default download resolution

Download Other Resolution

Next to any asset, you can click the down arrow dropdown to pick another resolution to download or import. Some assets may only have one size available for download.

Importing assets

Materials

You can import or apply materials by:

  • With one or more meshes selected, press the Apply button to generate the material and add it as a tag to all selected objects. Pre-existing material tags will not be removed.

  • Without any mesh selected, press the Import button on an asset and apply it later using the Material Manager.

You can further edit the material by double clicking the material in the shader tab.

Models

The first time you import a model, it will be imported according to the Model Grouping setting in plugin preferences. Thereafter, if you try re-importing the same model again, the plugin will offer you to perform a fresh import (recreating all materials and duplicating mesh data), or creating an instance of the pre-existing model import.

HDRIs

HDRIs are imported directly into the world. Simply press apply, or use the dropdown to select another resolution

My Account

View information about your account plan, including any subscription and details on when your asset balance will be topped off next. You can also log out, or open the website to view your plan details.

User Preferences

To open plugin preferences, click the cog icon at the top right of the plugin:

General and Libraries

  • Version: See the current version of the plugin and whether or not any updates are available.

  • Logging:

    • Verbose logging to console: Adds additional reports to the system console for debugging purposes.

    • Share plugin errors/usage: If enabled, unhandled exceptions as well as actions taken within the plugin, such as screen and menu views, will be reported to developers so that we can better maintain the plugin. This is the same tickbox selection made when first logging into the plugin.

  • Libraries: View and change the default library used for asset downloads as well as imports

Download and Import

  • Auto-download after purchase: Enabled by default, assets will automatically download after pressing purchase or buy.

  • Textures:

    • Default texture resolution: The default (closest) resolution size to download and import. For any given asset, you can still use the asset dropdown menu to pick another size to download or import different from the default.

  • Models:

    • Default Model Resolution: The default (closest) resolution size to download and import, in addition to the model's default resolution.

    • Default Model LOD: The default LOD (level of detail) model to import, if multiple LODs are already local for this asset. LOD0 is the densest, most detailed LOD while LOD 4 is lower density and more suitable for background or realtime use cases. Choosing None will import the default LOD level the asset was authored for.

    • Download Model LODs: If enabled, download LOD fbx files for any models supporting them.

  • HDRIs:

    • Default Light Resolution: The default (closest) resolution size to download and import.

  • Import:

    • Model Group Mode: How to place model assets on import

    • Use 16 bit maps: When enabled, use 16bit maps when available.

  • Thumbnail design:

    • Subtle Zoom: Default option that gives a slight zoom-in while hovering over an hover.

    • Zoom to Mouse: Zooms the mouse in further and follows the mouse position to help you preview an asset before purchasing.

    • Performance Mode: No zooming or movement during browsing.

Uninstalling the plugin

  1. Locate and open Cinema 4D’s plugin folder. To find this:

    1. Start Cinema4D

    2. Open preferences (Menu Edit → Preferences…”

    3. Click on the “Preferences Folder…” button at the bottom left

    4. Explorer/Finder will open with a Maxon folder selected (e.g. Maxon Cinema 4D 2023.2_…).

  2. Navigate the "plugins" sub-folder

  3. Delete the poliigon-plugin-cinema4d folder

If you want to do a full cleanup, you can additionally remove the following folders, without deleting your already downloaded assets:

  • {user home folder}/Poliigon/OnlinePreviews

  • {user home folder}/Poliigon/cinema4d

Did this answer your question?